Apache webserver på Windows Vista

Mar 2, 2007

Apache Web ServerSiden sidste gang jeg legede med Windows Vista har jeg haft lidt tid til at overveje endnu et forsøg - Og for ikke mange dage siden, tog jeg så mod til at gøre det igen! Denne gang fik hele harddisken en ordentligt formatering, og jeg fik delt mine partitioner op, så jeg nemt kunne lave en recovery, skulle alt gå helt af helvedes til...

Som jeg også skrev i denne post, understøtter mit grafikkort (Intel 915GM) ikke Vistas Eye Candy aka. Aero, og det lader der ikke til at være noget at gøre ved. Til gengæld fandt jeg ud af, at man på Acers egen side, har uploadet et par Vista Driver Updates.

Alt samme very good stuff, men overskriften vægter jo et lidt andet indhold, så lad og komme til sagen.

Som med alt nyt, er der altid lige en tid der hedder tilvending - det gælder software-udviklere, såvel som brugerne. Vista har som standard en funktion kaldet "User Control" slået til. Dette gør at man som almindelig bruger skal verificerer og godkende næsten alt hvad man laver. Det være sig at kopierer, slette og installerer noget på ens system-drev. Denne funktion kan dog slås fra, men på denne måde mister man jo noget af den "sikkerhed" der skulle være med VIsta.

Endnu en ny bruger-relateret feature i Vista, er muligheden for at udfører en handling som "Administrator". Man kan på alle eksekverbare filer vælge at kører disse som den bruger man er logget ind med, eller ved at højre-klikke på filen, vælge at kører filen med administrator rettigheder - og dette er nøglen her!
Da jeg skulle installerer Apache Webserver på min Vista box, kendte jeg ikke til denne feature, hvilket resulterede i at jeg ikke fik lov at installerer serveren som en "service". Løsningen er dog forholdsvis enkel, og jeg synes ikke jeg kan forklare det bedre end John Cox gør det herunder:

Go to Start | All Programs | Accessories, then right-click on "Command Prompt", and select "Run as administrator". This will open a command prompt window with admin rights. Navigate to the directory where you saved the apache*.msi install file, and type "msiexec /i apache*.msi" (where apache*.msi is the actual name of the file - hint: type apache and then hit tab, it should fill in the file name automatically). Hit enter, and the rest should work just fine, it did for me. Hope this helps.

Comments

comments powered by Disqus